[Battlemesh] Tplink wr1043nd internal/external antenna configuration and detection

cmsv cmsv at wirelesspt.net
Tue May 20 05:38:04 CEST 2014


On 03/11/2014 08:54 PM, Fernando Frediani wrote:
> Hi folks,
> Hopefully this is a easy one for you.
> I've got a TL-1043ND running Barrier Breaker (r39440). This router has 3
> detachable antennas and I have removed all of them in order to be able
> to use an external Sectorial antenna to reach a few other points in a
> mid-range distance.
> I have connected this Sectorial antenna to one of the RP-SMA connectors
> and left the other two without.
> On the /etc/config/wireless I'm using the following relevant lines:
>         option diversity '0'
>         option rxantenna '0x1'
>         option txantenna '0x1'
> Which supposedly means it will only use that antenna port. Or if I want
> to use the use the 3rd antenna port '0x4'.

I have one one these routers and at some point i had a similar problem
that i thought i had solved.

system type		: Atheros AR9132 rev 2
machine			: TP-LINK TL-WR1043ND

For the longest time and with AA r39154 i was only able to get 4 or 5
results when scanning for ssid's using a 15 dbi omni antenna.

Since the router was and is in a very far remote location i was only
able to play with the physical setup about 3 months ago.

While playing with the configuration and having the router physically
using the omni antenna with rp-sma connector number 2 (middle one) i did
not get better results. I tried to change to connector 3 and also no
better results until i moved it to connector 1 (counting from the left
when you have the router front facing you).

While setting it with connector number 1 and adjusting the configuration
i was able to get 22 SSID's and so i though the problem was solved.
About less than 2 months and without any other changes; the router went
by itself to the previous bad performance and was detecting only about 4
or 5 ssid's.

At the time the setup was :
Configured Antennas: TX 0x1 RX 0x1

Available Antennas: TX 0x7 RX 0x7

Strangely it did work quite well for a while even tho it showed that the
available antenna was not the one configured.

However it did not last long and i have been trying to figure out why it
stopped being able to detect those 22 ssdi's and why i don't see it
working as well as before when it gave me 22 ssid scan results.

According to:
~# iw phy phy0 info | grep -i ant
	Available Antennas: TX 0x7 RX 0x7
	Configured Antennas: TX 0x7 RX 0x7

0x7 is the same as wireless.radio0.txantenna=7 which is not 1, 2 or 3.
or am i wrong ? Where exactly is antenna 7 ?

My first question is: which antenna is this one ? Any of the 3 rp-sma
connectors ?

Changing wireless.radio0.diversity on and off also does not seem to help
or change anything.

Recently i updated the firmware to r40757 and there was no improvement.

I also find it very odd that a nearby access point is able to detect
this AP with SNR of 40 dbm while from the 1043nd side i only detect the
other access point with 5 ~ 9 dbm SNR.

To me this tells me that TX and RX is not working well for the 1043nd

Can someone shed some light into this from their own experience or are
these builds broken ?

> Is it the correct way of using external antennas on these types of
> routers ? Does using it in this way make sure there is no loss of signal
> via the other ports ?
> Or must the other two ports have some type of antenna even if it's a
> different type like the original Omnis ?
> Anyone had a similar experience and can help clarifying it ?
> Thanks and best regards,
> Fernando
> _______________________________________________
> openwrt-users mailing list
> openwrt-users at lists.openwrt.org
> https://lists.openwrt.org/cgi-bin/mailman/listinfo/openwrt-users
-------------- next part --------------
A non-text attachment was scrubbed...
Name: 0x15C4B382.asc
Type: application/pgp-keys
Size: 36238 bytes
Desc: not available
URL: <http://ml.ninux.org/pipermail/battlemesh/attachments/20140519/80782116/attachment-0003.key>

More information about the Battlemesh mailing list